Running PianoBooster on MacOs Catalina 10.15.5

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Running PianoBooster on MacOs Catalina 10.15.5

DumitruMalinovschii
When trying to launch the application on MacOs Catalina i'm getting the error saying:

Piano booster cannot be started because of a problem

Am i the only one getting this error? Looking forward to your replies

Reply | Threaded
Open this post in threaded view
|

Re: Running PianoBooster on MacOs Catalina 10.15.5

Louis B.
Administrator
I only have an old Mac Book Air that has not been updated to the latest OS. I was hoping that the version I built would work on all newer OSes, but obviously not. There is a version that has been built by the automated build system please try this version https://github.com/pianobooster/PianoBooster/actions/runs/418999254

Please let me know if it works for you and if it does please can you post a screenshot here.

Piano booster will not work on the latest MacOS that has an ARM processor.

If you want to try building it yourself please see these commands.

https://github.com/pianobooster/PianoBooster/blob/develop/BUILD.md
https://github.com/pianobooster/PianoBooster/blob/develop/.github/workflows/build.yml

I am look for volunteers to help test MacOS builds.